BerryBots forums

It is currently Wed Oct 20, 2021 12:28 pm

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Thu Oct 24, 2013 5:42 am 
Offline

Joined: Sat Oct 19, 2013 11:06 pm
Posts: 15
Yip ~/.berrybots was my installation folder, deleted that now and it works fine. You could put the config file in ~/.config or rather $XDG_CONFIG_HOME if set to keep with the xdg spec.


Top
 Profile  
 
PostPosted: Thu Oct 24, 2013 11:41 pm 
Offline
Site Admin
User avatar

Joined: Sat Nov 17, 2012 5:03 am
Posts: 88
Whew, that's a relief! Cool, looks like $XDG_CONFIG_HOME or fallback to $HOME/.config is the way to go.

I really appreciate all your help with this btw. I'm not unfamiliar with Linux, but it's also not quite my primary OS, and building/packaging desktop apps in general is pretty new to me. This is getting done a lot faster and more correctly thanks to your input.


Top
 Profile  
 
PostPosted: Fri Oct 25, 2013 1:19 am 
Offline
Site Admin
User avatar

Joined: Sat Nov 17, 2012 5:03 am
Posts: 88
And here's the updated source if you're interested: berrybots_src_1.3.1-beta2.zip


Top
 Profile  
 
PostPosted: Fri Oct 25, 2013 1:27 am 
Offline

Joined: Sat Oct 19, 2013 11:06 pm
Posts: 15
No problem, I appreciate you making BerryBots more! Sorry I can't be more help with the deb/rpm packaging.


Top
 Profile  
 
PostPosted: Thu Nov 14, 2013 1:52 am 
Offline

Joined: Sat Oct 19, 2013 11:06 pm
Posts: 15
Updated to 1.3.1 https://aur.archlinux.org/packages/berrybots/

@Voidious I patched the Makefile.in to get the make install working when sfml was provided, I'm guessing it was just an oversight that it didn't work, have a look at the patch if you are interested.


Top
 Profile  
 
PostPosted: Thu Nov 14, 2013 3:29 am 
Offline
Site Admin
User avatar

Joined: Sat Nov 17, 2012 5:03 am
Posts: 88
Sweet! I'll add a link to the Download page shortly.

And doh, yeah, my bad on the install with installed SFML. Your patch makes sense and I'll incorporate it into the next version.


Top
 Profile  
 
PostPosted: Sat Dec 28, 2013 11:24 pm 
Offline

Joined: Sat Oct 19, 2013 11:06 pm
Posts: 15
------------------------------- Updated to 1.3.2 -------------------------------------

@Voidious I built this on a new computer and realised that "wx-configure --libs" drags in a bunch of unneeded make dependencies (webkit and it's dependencies) "wx-configure --libs core,adv" are all that are needed for the compilation.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group